Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T43 Wireless Issues With Windows 2000

T40/T41/T42/T43 series specific matters only
Post Reply
Message
Author
Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

T43 Wireless Issues With Windows 2000

#1 Post by Qrani » Wed May 06, 2020 1:13 pm

I decided to install Windows 2000 on my Thinkpad T43 since it's practically the same as Windows XP under the hood, but I prefer the classic Windows look. I installed all of the drivers just fine, except for the wireless driver. The computer has the Intel PRO/Wireless 2200BG adapter, and after installing the drivers, I can't run the utility that allows you to connect to a network, and it always says "Error loading plug-ins. Application will exit.", meaning that I'm not actually able to connect to a network. I don't understand why this is happening. When I use the same installer program on Windows XP, and try to run the utility it always worked, and the program is listed as being compatible with Windows 2000/XP.
  • Thinkpad 770z
  • Thinkpad T43

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16930
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T43 Wireless Issues With Windows 2000

#2 Post by ajkula66 » Wed May 06, 2020 2:07 pm

Which "utility" exactly are you referring to ?
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

FlexView AARP club members:A31p, T43pSF

Abused daily: T520, X200s


PMs requesting personal tech support will be ignored.

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#3 Post by Qrani » Wed May 06, 2020 3:00 pm

I went to this page for my drivers: https://thinkpads.com/support/Thinkpad- ... m/T43.html, and went down to the Wireless LAN section, and got the 2200BG drivers. I used the executable I download, and ran it. The executable put the driver setup in C:\DRIVERS\WIN\WLANCX2A. I then ran the driver setup, installing the drivers and also installing a utility called iFrmewrk.exe in C:\Program Files\Intel\Wireless\Bin. When trying to run that executable, it says Error loading plug-ins. Application will exit. If I try clicking the button showing that I'm not connected on the system tray, it brings me to the control panel called Network and Dial-up Connections, and I'm not able to do it from there. I also tried running the other programs in C:\Program Files\Intel\Wireless\Bin, but none of them did anything at all.
  • Thinkpad 770z
  • Thinkpad T43

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1775
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: T43 Wireless Issues With Windows 2000

#4 Post by kfzhu1229 » Wed May 06, 2020 7:50 pm

What I used to use when I put my T42 and T43 in Windows 2000 some years ago is an utility called ThinkVantage Access connections. It takes a little longer to connect but is a lot more advanced than the built in Intel utility.
I used this version off Lenovo ThinkPad support China
https://think.lenovo.com.cn/support/dri ... 26osid%3D7
P.S. When I was trying to find the utility on Lenovo's North America website, I realised how terrible that website is in terms of support. it doesn't offer drivers for anything older than the Sandy Bridge generation. Last time I used that website was like 4 years ago and all the T4x series were up there. I always use think.lenovo.com.cn as it has far, FAR better driver support but the drivers might not be available in English.
Take a look at that webstite if you can make out the rough translation - it has drivers from all the way back into the 760 series. Granted that is still not as much of an archive as Dell's driver support still providing drivers for even the original Dell Latitude (Latitude XP 4) but still.
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 160gb WUXGA Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#5 Post by Qrani » Wed May 06, 2020 10:53 pm

I wasn't able to use the software you linked to me since it wasn't in English, but I found a piece of software called IBM Access Connections, which I'm guessing is just the older name for it. The software version was 3.53, from 2004. When I tried to run the program after installing it, it kept saying that the radio was off, and would do nothing every time I tried to turn it on. Is there a different version of the software that would work?

Software download link: https://pcsupport.lenovo.com/us/en/downloads/ds013802
  • Thinkpad 770z
  • Thinkpad T43

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21591
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T43 Wireless Issues With Windows 2000

#6 Post by RealBlackStuff » Thu May 07, 2020 1:34 am

That wifi card is a rather senior item, have you tried other card(s)?
NOT a great day for a Guinness! (the Real Black Stuff).
Ireland is on FULL lockdown till December 2020!
Covid-19: Mask it or Casket!
Check out The Boardroom for Mods and Other Services.

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16930
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T43 Wireless Issues With Windows 2000

#7 Post by ajkula66 » Thu May 07, 2020 2:01 am

Qrani wrote:
Wed May 06, 2020 10:53 pm
I wasn't able to use the software you linked to me since it wasn't in English, but I found a piece of software called IBM Access Connections, which I'm guessing is just the older name for it. The software version was 3.53, from 2004. When I tried to run the program after installing it, it kept saying that the radio was off, and would do nothing every time I tried to turn it on.
This brings back memories of why I hated Intel cards back then, not that I'm in love with them now by any means.

You may want to dig deep and see whether there's still the Intel's version of the XP driver available somewhere on Intel's site. If you find it, bypass the whole Access Connections thing and just update the driver manually.

Good luck. You'll need it.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

FlexView AARP club members:A31p, T43pSF

Abused daily: T520, X200s


PMs requesting personal tech support will be ignored.

MikalE
ThinkPadder
ThinkPadder
Posts: 1327
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: T43 Wireless Issues With Windows 2000

#8 Post by MikalE » Thu May 07, 2020 9:49 am

Or just buy a wi-fi USB dongle for $13 on Amazon and be done with it.
A31p P-IV 2Ghz, 2MB, 2653-R6U
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7QM 4242-4UU Highly Modified

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#9 Post by Qrani » Thu May 07, 2020 11:34 am

@RealBlackStuff: I can't figure out how to open up the keyboard on the computer, nor do I know where the card is, or what type. I have some cards laying around, but I don't know if they would work in the computer.

@ajkula66: No matter where I look for a working driver, I can't find one.

@MikalE: I probably won't be able to find a USB dongle that will support Windows 2000.
  • Thinkpad 770z
  • Thinkpad T43

MikalE
ThinkPadder
ThinkPadder
Posts: 1327
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: T43 Wireless Issues With Windows 2000

#10 Post by MikalE » Thu May 07, 2020 1:47 pm

A31p P-IV 2Ghz, 2MB, 2653-R6U
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7QM 4242-4UU Highly Modified

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1775
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: T43 Wireless Issues With Windows 2000

#11 Post by kfzhu1229 » Thu May 07, 2020 2:35 pm

Qrani wrote:
Wed May 06, 2020 10:53 pm
I wasn't able to use the software you linked to me since it wasn't in English, but I found a piece of software called IBM Access Connections, which I'm guessing is just the older name for it. The software version was 3.53, from 2004. When I tried to run the program after installing it, it kept saying that the radio was off, and would do nothing every time I tried to turn it on. Is there a different version of the software that would work?

Software download link: https://pcsupport.lenovo.com/us/en/downloads/ds013802
IBM Access Connections is the older version of it but I don't think that supports WPA2 like ThinkVantage Access Connections do.
Also, as far as I know of, all of Lenovo ThinkPad Support China's drivers are that it's only the unzipping process that is only available in Chinese, the actual setup works in English as well. Can't test that myself as all my Windows 2000 installations are Chinese. Just set the directory to unzip it to and press enter and it will unzip just fine even if the text in that window is unreadable.
I can confirm at least the setup page is available in English (can't proceed to install it as this is on Windows 10 and on a Dell)
https://1drv.ms/u/s!At7-rt1KJ7WviPhIrdw ... A?e=wrEAWd
Note that on the description page it says
Before installing ThinkVantage Access Connections, please install the following list of software first:
[ThinkPad SL Series] ...
[Other models]
ThinkPad Power Management driver (98SE/Me/2000/XP/Vista) version 1.42 or higher
ThinkPad Hotkey driver (98/98 SE/Me/NT 4.0/2000/XP) version 1.24.0603 or higher, or Hotkey driver (Vista/XP/2000) 2.08.2008 or higher
To make your search easier, these are the power management driver and the hotkey driver respectively:
https://think.lenovo.com.cn/support/dri ... 26osid%3D7
https://think.lenovo.com.cn/support/dri ... 26osid%3D7
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 160gb WUXGA Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#12 Post by Qrani » Thu May 07, 2020 9:31 pm

When I try to run the Access Connections setup, at the end it says that I need .NET 3.0, but I can't find it for Windows 2000.
  • Thinkpad 770z
  • Thinkpad T43

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1775
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: T43 Wireless Issues With Windows 2000

#13 Post by kfzhu1229 » Thu May 07, 2020 11:06 pm

Qrani wrote:
Thu May 07, 2020 9:31 pm
When I try to run the Access Connections setup, at the end it says that I need .NET 3.0, but I can't find it for Windows 2000.
Oh yeah right I remember I ran into that issue before, I remembered I ended up using an older version found on Baidu some years ago.
Luckily I still have the hard drive that I used for Windows 2000 and I kept it as a "time capsule" seeing one day it will come into use or one day I decide to dig into it and see the stuff I did years ago.
However I wasn't able to find the setup files for that older version, but I have it installed in Windows 2000, so I checked the version and it was 4.42 from 2007.
Then I searched that version up on Baidu, only to find download sites referring to the Lenovo archive of that file which is gone now. And then I searched up the filename of that archive file through a TB worth of archive files of mine on my Baidu cloud and I found it!
Here I have put it in onedrive so you can download it easily:
https://1drv.ms/u/s!At7-rt1KJ7WviPhK_3n ... g?e=4E84eU
I can confirm it works with Intel 2200BG card that I have. However I have trouble getting it to work with 2100 series cards and for those the connection settings are baked into the driver's configuration tab anyways.
Sorry for this confusion, it has been a very long time since I last set up Windows 2000 for internet use :roll:
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 160gb WUXGA Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#14 Post by Qrani » Fri May 08, 2020 10:17 am

Thanks! The program now works! When I tried to join my network for the first time, it always got stuck in the same part, but I fiddled with some settings, and got it connected to my network! Now all I need is a good browser. I've looked online, and every browser I've found for Windows 2000 is an older version of a recent browser, which you can't find, and the newer version doesn't work. All of the ones I've tried said that it wasn't a valid Win-32 application, one of them worked but blue-screened at some point. I downloaded the 32-bit version of all of them. Also, this is my first time using Windows 2000 not in a VM!
  • Thinkpad 770z
  • Thinkpad T43

MikalE
ThinkPadder
ThinkPadder
Posts: 1327
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: T43 Wireless Issues With Windows 2000

#15 Post by MikalE » Fri May 08, 2020 12:10 pm

Have you tried Comodo Dragon? I have it working with 32 bit XP.
A31p P-IV 2Ghz, 2MB, 2653-R6U
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7QM 4242-4UU Highly Modified

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#16 Post by Qrani » Fri May 08, 2020 12:24 pm

I tried Pale Moon 26.5, which blue-screened after opening, and I couldn't find a Comodo Dragon setup that would run in the first place.
  • Thinkpad 770z
  • Thinkpad T43

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1775
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: T43 Wireless Issues With Windows 2000

#17 Post by kfzhu1229 » Fri May 08, 2020 12:49 pm

Qrani wrote:
Fri May 08, 2020 10:17 am
Thanks! The program now works! When I tried to join my network for the first time, it always got stuck in the same part, but I fiddled with some settings, and got it connected to my network! Now all I need is a good browser. I've looked online, and every browser I've found for Windows 2000 is an older version of a recent browser, which you can't find, and the newer version doesn't work. All of the ones I've tried said that it wasn't a valid Win-32 application, one of them worked but blue-screened at some point. I downloaded the 32-bit version of all of them. Also, this is my first time using Windows 2000 not in a VM!
I used Firefox 12 back in the day, but since that software is from 2012 many sites no longer works with it...
And yeah I know that program can be cumbersome to set up at first, and occasionally you might need to connect twice to get it to work, but it is the only FREE software I was able to find that works with WPA2 protocol in Windows 2000. I know this software because it came with my ThinkPad T43 before Windows XP has the functions built in
And now I know indeed that download works just fine in English
Also, I have used Windows 2000 primarily back then so much that I have an archive of the software that I used back then with the last versions that would work in Windows 2000. Many may not support English out of the box like this one did, but at least the version numbers can be helpful to you
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 160gb WUXGA Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

dr_st
Moderator
Moderator
Posts: 8659
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T43 Wireless Issues With Windows 2000

#18 Post by dr_st » Fri May 08, 2020 1:07 pm

Qrani wrote:
Fri May 08, 2020 10:17 am
Now all I need is a good browser. I've looked online, and every browser I've found for Windows 2000 is an older version of a recent browser, which you can't find, and the newer version doesn't work
Enjoy the read:
https://www.vogons.org/viewtopic.php?t=12102
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#19 Post by Qrani » Fri May 08, 2020 1:51 pm

I tried K-Meleon 74, which works, but is very buggy. Whenever I type into the address bar at the top, it usually just infinitely tries to load the page with no luck in actually doing so. I got it to go to Google twice, but it's not exactly that great. And sometime when I try to load a page, for example searching in the search bar, it will just blue-screen. I was able to get to Youtube, which couldn't do video playback, but everything else on the page was fine.
  • Thinkpad 770z
  • Thinkpad T43

dr_st
Moderator
Moderator
Posts: 8659
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T43 Wireless Issues With Windows 2000

#20 Post by dr_st » Fri May 08, 2020 1:56 pm

This behavior may be not only due to the browser but also due to missing buggy codecs / video card drivers. Windows 2000 is really not something anyone expects to be on the web today.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1775
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: T43 Wireless Issues With Windows 2000

#21 Post by kfzhu1229 » Fri May 08, 2020 3:11 pm

Qrani wrote:
Fri May 08, 2020 1:51 pm
I tried K-Meleon 74, which works, but is very buggy. Whenever I type into the address bar at the top, it usually just infinitely tries to load the page with no luck in actually doing so. I got it to go to Google twice, but it's not exactly that great. And sometime when I try to load a page, for example searching in the search bar, it will just blue-screen. I was able to get to Youtube, which couldn't do video playback, but everything else on the page was fine.
I'd imagine Windows 2000 for web browsing these days is no more than browsing over this ThinkPad forum... I believe Firefox 12 can still do that at least - if you have Service Pack 4 installed, which you should.
There are converter programs that can enable a Windows XP software work in Windows 2000, but it would be really buggy and you might as well step up to Windows 7 at that point, which the T43 runs it pretty fine as long as you have the ATi graphics.
Having bluescreens with those apps is just defeating the point of Windows 2000 though. My positive experience from Windows 2000 mainly comes from that I have seen no bluescreens with a software fault once the proper drivers are installed - only bluescreens from the likes of a corrupted hard drive or faulty RAM.
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 160gb WUXGA Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

Qrani
Posts: 20
Joined: Mon Nov 25, 2019 9:44 pm
Location: Ann Arbor, Michigan

Re: T43 Wireless Issues With Windows 2000

#22 Post by Qrani » Fri May 08, 2020 4:59 pm

Firefox 12 will run, just it won't actually go to any webpages, except the home page. I tried running the Opera 12.02 install program, and it did nothing.
  • Thinkpad 770z
  • Thinkpad T43

Callahan
Freshman Member
Posts: 123
Joined: Fri Nov 25, 2016 7:37 am
Location: Huntingdon, PA

Re: T43 Wireless Issues With Windows 2000

#23 Post by Callahan » Fri May 08, 2020 6:22 pm

There may be some help for a browser over at the MSFN forum. There are several browsers maintained by roytam1. He updates all or some every weekend. We are just hours away from any new updates for the week. He lives in Hong Kong and just showed up one day several years ago. He started with a few browsers for XP ... including K-Meleon and now may have 8 or 10 browsers for various users.

Under 'New build of Serpent/UXP for XP!' ... I use his New Moon build ... NM28XP build. The last update is from last Sat May 02, 2020 and in a few hours there may be a new May 09th update. You may find something interesting there if you explore that area. He does Firefox and K-Meleon also for Windows XP.

My browser builds (part 2) ...

Older Windows NT-Family OSes

https://msfn.org/board/forum/183-older- ... mily-oses/

roytam1 - Posted May 2

https://msfn.org/board/topic/180462-my- ... 2/page/80/

...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T40/T41/T42/T43 Series”

Who is online

Users browsing this forum: No registered users and 49 guests