Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T601 driver issues

T60/T61 series specific matters only
Post Reply
Message
Author
H-Atkinson
Freshman Member
Posts: 110
Joined: Tue Sep 10, 2019 10:27 pm
Location: Glendale, CA

T601 driver issues

#1 Post by H-Atkinson » Mon Nov 25, 2019 6:03 pm

I recently built 2 more T601s and am having some driver issues with one of the machines. (both have X9000, FX750m, 8 gb, LED UXGA, Windows 7 Ultimate x64).

On one of the machines, the UltraNav drivers install, but the middle scrolling wont work. Its the same driver I used on the other machine, and it worked there. I tried swapping the keyboards around and it still wont work. I have tried drivers for both T60 and T61.

I also installed the Hotkey integration package, and all of the FN keys work as they should, but the mute key wont work, and the on-screen display for brightness and volume wont show up when I change those through the keyboard shortcuts. I have tried drivers for both T60 and T61.

Im using a xx30 bluetooth card, and the driver isnt working. (I tried the lenovo-provided one, again it worked on my other machine but for some reason this one it isnt).

Has anyone had these issues before? I had something similar to the mute key issue before and fixed it with the T60 driver, but have had no such luck this time.
T43p, T61p, T601p, T601 (dead), T601, T60p (Prototype), X230, P53, T480 (In the process of rebuilding)

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21168
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T601 driver issues

#2 Post by RealBlackStuff » Tue Nov 26, 2019 12:55 am

Have you tried swapping the HDD/SSD between them?
Do they have the same chipset drivers?
Same wifi cards, same RAM?
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

wujstefan
ThinkPadder
ThinkPadder
Posts: 1256
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: T601 driver issues

#3 Post by wujstefan » Tue Nov 26, 2019 3:22 am

Now now.

For scrolling - this is due to one of Windows 10 updates and, on some point, Windows 7 that will not enable both scrolling and middle click (only one can be active) - this could be fixed with an app built by a fellow thinkpadder - tpmiddle. Works perfectly on all my W7+ systems.

For ultranav... pretty much the same :D Lenovo nerfed the ultranav / OSD drivers at some point. I will pack up working drivers and post it later on. If I don't please send me a reminder.

As for Bluetooth... no idea!
Too many thinkpads not enough time!
(stable under reduction)

H-Atkinson
Freshman Member
Posts: 110
Joined: Tue Sep 10, 2019 10:27 pm
Location: Glendale, CA

Re: T601 driver issues

#4 Post by H-Atkinson » Wed Nov 27, 2019 6:48 pm

Ill try that fix for windows 7.

As for hardware, the systems are identical.

When swapping drives, it seems to be related to my particular windows install.
T43p, T61p, T601p, T601 (dead), T601, T60p (Prototype), X230, P53, T480 (In the process of rebuilding)

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21168
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T601 driver issues

#5 Post by RealBlackStuff » Thu Nov 28, 2019 1:00 am

Rather than searching for that needle in the haystack, why not just copy/clone the working HDD/SSD onto the non-working one?
With Slic in BIOS (thanks Middleton), it shouldn't be a problem.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16848
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T601 driver issues

#6 Post by ajkula66 » Thu Nov 28, 2019 12:26 pm

RealBlackStuff wrote:
Thu Nov 28, 2019 1:00 am
Rather than searching for that needle in the haystack, why not just copy/clone the working HDD/SSD onto the non-working one?
With Slic in BIOS (thanks Middleton), it shouldn't be a problem.
+1

A long time ago I created an image that I used on these systems and saved myself a bunch of time and aggravation when compared to doing an install "from scratch".

Good luck.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

FlexView AARP club members:A31p, T43pSF

Abused daily: T520, X200s


PMs requesting personal tech support will be ignored.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: axur-delmeria and 28 guests