Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

10.6.3 on a T60p 8741-CU1, thanks to Silencer! Some issues..

OS-X on ThinkPads
Post Reply
Posts: 1
Joined: Sat Feb 12, 2011 6:53 pm
Location: Charleston, SC

10.6.3 on a T60p 8741-CU1, thanks to Silencer! Some issues..

#1 Post by retack » Sun Feb 13, 2011 2:57 am

This laptop is great! I picked it up off craigslist for $150 somehow, all it needed was a new battery.

I went with the T60p files that Silencer said he made for someone with a 15.4" V5250 T60p in this post, but that led to an instant kernel panic in ATIRadeonx1000.kext every startup. I wasn't able to start up normally until I patched the binary kext to include my device ID (71D4), is this normally required?

Other things I noticed:
- Sound is funky - the microphone works, but the speakers/headphone port won't make any noise. If I hit the 'volume up' button on the laptop's keyboard, sound output will start working. Seems to have a slight sub-second delay. Weird.
- Sleep doesn't work. It'll go to sleep fine, but never wake up. Have to then start up with Wake=No argument. I have read this is probably because of non-vanilla audio.
- Getting "ACPI_SMC_CtrlLoop::loadStepperProgram = pmCPUControl (PMIOCSETPSTATESTEPPER) failed, result - 0x4" in the startup log, nothing else seems out of the ordinary.

I noticed the T60p files Silencer posted were from March 2010, and later in the thread he has a newer archive for his own different T60p - I installed the newer dsdt.aml along with the newer FakeSMC.kext. I didn't get the fan/temperature readouts/control that it is apparently capable of, nor did it change sleep or sound behavior.

I tried updating to 10.6.6, and had to re-patch ATIRadeonX1000.kext. After getting past that and running pfix over the system, things are running mostly the same as before - sound works only after pressing hardware volume-up button, sleep is busted, iStat can't see any hardware temps/fans/etc., but the pmCPUControl error is gone!

Is anyone here using a T60p similar to mine, and has a full system running? I'd love a pre-packaged working setup (wouldn't everyone?). Again it's a T60p 8741-CU1, 15.4" 1680x1050 screen on a V5250 FireGL. Also if anyone cares, or has a use for it, here's a link to my windows-extracted DSDT.aml and EDID, and the most recent 10.6.3 kernel startup log.

And thanks to everyone here! I've already learned a lot just from poring over this forum for the last couple days.

Posts: 8
Joined: Mon Jul 26, 2010 7:28 am
Location: Lisboa, Portugal

Re: 10.6.3 on a T60p 8741-CU1, thanks to Silencer! Some issues..

#2 Post by downlord » Fri May 20, 2011 8:21 am

Hi, having a very similar system, and all I can say that the "prepackaged setup" is almost impossible for this system.

But if you have specific Q, feel free to ask.
BTW v5250 is a big PITA. It's very similar to the x1700 mobility card but works AFAIK only with the ATINDRV from 10.5.
10.6.7 changed the way the framebuffers (the graphic drivers) are called, so I'm stuck with 10.6.6.

Speedstep works sometimes, sometimes not, seems randomly activated or blocked.

When I've some time, maybe I'll spend some time on reconfiguring all.

Good luck
T420 4180A32, MACOS 10.9, WIN7

Posts: 7
Joined: Tue May 17, 2011 11:05 am
Location: Melbourne, Australia

Re: 10.6.3 on a T60p 8741-CU1, thanks to Silencer! Some issues..

#3 Post by yaboo » Sun May 22, 2011 9:46 am

I use nawcom mod cd to install snow leopard and everything works out of the box except the x3100 video card. This was resolved for me, when I forced the machine to boot 32bit.

Junior Member
Junior Member
Posts: 345
Joined: Sat Dec 25, 2004 8:17 pm
Location: Riga, Latvia

Re: 10.6.3 on a T60p 8741-CU1, thanks to Silencer! Some issues..

#4 Post by Silencer » Sun Jun 19, 2011 3:08 pm

Sorry I haven't updated the original DSDT thread for a while, there have been some updates.

Unfortunately V5250 is rather tricky compared to V5200, which now works almost out of the box. One shouldn't use my /Extra package unchanged with V5250, because com.apple.Boot.plist has 'device-properties' string specifically tuned for V5200. That is why you had kernel panics with ATIRadeonX1000.

With sound and never being able to wake up - I solved this somewhere in BIOS by disabling/enabling built-in modem/WAN, can't remember all details now. I use VoodooHDA.kext, one of older builds. Sleep works just fine.

ACPI_SMC_CtrlLoop error means you have a different OSX version than the one I had /Extra prepared for. Then you installed later package and the error was gone.

For video I would look into RadeonHD.kext solution, although I've never tried it with V5250 so I can't guarantee it working.
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)

Posts: 11
Joined: Fri Jan 28, 2011 11:48 pm
Location: West Hills, CA

Re: 10.6.3 on a T60p 8741-CU1, thanks to Silencer! Some issues..

#5 Post by musashiz » Mon Dec 03, 2012 2:21 am

I too have a t60 with x1400 w/ sleep and radeonhd.kext madchicken's version. 32bit only due to radeonhd 32bit limitation. Its a variation of silencers extra folder. question. did you end up getting your t60p working? wondering if your bluetooth wakes from sleep?? its the bcm2045b.
IBM T61 7663
Core2Duo T9300
RunCore SSD 128GB

Post Reply
  • Similar Topics
    Last post

Return to “OS-X Questions”

Who is online

Users browsing this forum: No registered users and 3 guests