Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X201 Wifi Card Stopped Working

X200/X201/X220 (including equivalent tablet models) and X300/X301 series specific matters only.
Post Reply
Message
Author
Rob
Sophomore Member
Posts: 147
Joined: Sun Aug 07, 2005 4:52 pm
Location: Lorton, VA (USA)

X201 Wifi Card Stopped Working

#1 Post by Rob » Wed Jul 01, 2020 3:56 pm

I've tried searching around for a solution, but haven't been able to find something that works.

This happens on a ThinkPad X201 with the Centrino 6200 card.

Here what happened.

I purchased a used ThinkPad X201. Everything was working, including Wifi. Since this is for my collection, I wanted to restore the original Win7 image that came on the computer onto a spare hard drive.

I used a Windows 7 Pro system recovery disk set to restore the computer. After the restore completed, the wifi card is no longer found. It's not even displaying in the Device Manager. I swapped in another other hard drive with Windows 10 on it, and still the wifi card is no longer found. I think I must have had a hardware fault.

Good thing I have a second X201, I think. I swap the wifi card from that laptop over the restored machine still can't find it. Meanwhile both wifi cards work great in the second X201 either on Win7 or Win10.

Fast forward, and I'm on the second X201 and without really thinking do another Win7 Pro restore. Now the wifi stops working on that computer. I've tried both wifi 6200 cards with both Win7 and Win10.

Now I'm thinking it must be something with that restore. I can't possibly have had 2 hardware failures following a Win7 recovery. Perhaps there was some chipset firmware that was reverted or something. I've tried my google-fu, but I've tried all the driver files people have mentioned to no avail. Does anyone have any ideas on what is going on and how to fix it?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21512
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: X201 Wifi Card Stopped Working

#2 Post by RealBlackStuff » Thu Jul 02, 2020 12:02 am

(Re)install the Intel Chipset drivers from: https://download.lenovo.com/eol/index.html
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or Casket!

muga_thinkpads
Posts: 2
Joined: Sat Jul 25, 2020 6:50 pm
Location: awaiting correct location **

Re: X201 Wifi Card Stopped Working

#3 Post by muga_thinkpads » Sat Jul 25, 2020 7:01 pm

For this same reason is why i joined this forum. It's been happening to me for awhile also and seem to work once i either did a system restore or installed the wifi drivers multiple times. At first i was thinking that maybe win10 wasn't recognizing the wifi card and so i tried using linux and was having the same issue. Now for me i was just about to wipe the HDD and install only linux and see if that helped but read some where and someone suggested that the hardware switch might be the culprit but i was still skeptical because was wondering why it worked after doing a system restore then. Anyways long story short what i realize that helps is for me to switch off the wifi hard switch on the left side of the laptop and then boot up into win10 and then after the boot is complete and I'm on the desktop i just switch the wifi on and that seems to work for me. Give it a try and see if that helps. Ps: I have different wifi drivers downloaded and also but once the wifi stops working you can't even find the wifi card in device manager like the OP says so can't even do a updating of the drivers from there and after getting it working again and did an update it says that it has the latest version. Don't know if this problem is just confined to the Intel Celeron versions or the i5's also.

shawross
Senior Member
Senior Member
Posts: 557
Joined: Mon Oct 28, 2013 5:48 am
Location: Perth Aus / Thailand

Re: X201 Wifi Card Stopped Working

#4 Post by shawross » Sat Jul 25, 2020 8:05 pm

Resetting the embedded controller can help problems like these by removing the battery and holding down power button for about 15 seconds.
Active --- Love the X series
X301 W 7/Mint | X201 540M L Mint | X220 2520 W7/Mint

Nostalgia
X61 T7500 / T41 T42 T43 / A31

Rogue daily driver - Samsung RV511 15.6 " Screen - W 7

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/X201/X220 and X300/X301 Series”

Who is online

Users browsing this forum: Bing [Bot] and 27 guests