Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

ThinkPad T400 LCD not illuminated (no backlight) *PICS*

T400/410/420 and T500/510/520 series specific matters only
Message
Author
oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

ThinkPad T400 LCD not illuminated (no backlight) *PICS*

#1 Post by oliversl » Wed Nov 14, 2012 9:56 am

Hi,
I have a T400 that has a LCD problem, the simtoms are:
- you can see the LCD is working(booting to windows), but without brightness, as it has no backlight
- all the green LED indicators does not work, on the WiFi and Bluetooth works

The T400 is out of warranty, and I'm weighting my options.

Should I buy a new inverter, cable or LCD panel? Is there a easy way to find out
what component failed(inverter, cable, panel)?

Many thanks
Oliver

Admin edit: Added PICS warning.
http://tinymailto.com/oliversl <-- my email after a captcha

ZaZ
Moderator
Moderator
Posts: 4524
Joined: Fri May 13, 2005 1:33 pm
Location: Minnesota

Re: ThinkPad T400 LCD not illuminated (no backlight)

#2 Post by ZaZ » Wed Nov 14, 2012 2:49 pm

Maybe as a first step, hook it up to an external screen to see if it works.
ProBook 470 G3

jayton4
Senior Member
Senior Member
Posts: 618
Joined: Mon Dec 12, 2011 9:00 am
Location: United States

Re: ThinkPad T400 LCD not illuminated (no backlight)

#3 Post by jayton4 » Wed Nov 14, 2012 7:33 pm

oliversl wrote:Hi,
I have a T400 that has a LCD problem, the simtoms are:
- you can see the LCD is working(booting to windows), but without brightness, as it has no backlight
- all the green LED indicators does not work, on the WiFi and Bluetooth works

The T400 is out of warranty, and I'm weighting my options.

Should I buy a new inverter, cable or LCD panel? Is there a easy way to find out
what component failed(inverter, cable, panel)?

Many thanks
Oliver
I would try inverter first since they are so cheap, but it is very likely to be the screen. If your T400 has the 1280x800 screen, it would be a great time to upgrade the 1440x900.
jayton4
Current models/upgrades:
T410 2518X01- 8GB, Corsair Force GT 120GB
T410s 2901A3U- 8GB, Intel 6300 WiFi, Crucial m4 mSATA 256GB SSD w/ microSATA adapter
T420s 4174PPU- 16GB, Intel 520-series 7mm 180GB SSD, Crucial M550 512GB mSATA SSD, Intel 6300 WiFi
and a few classics in storage

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#4 Post by oliversl » Fri Nov 16, 2012 1:32 pm

Thanks Zaz and Jayton,
I can see that the screen is working fine. It just does not have any backlight.

Will try to purchase an inverter and report back.

Regards,
Oliver
http://tinymailto.com/oliversl <-- my email after a captcha

hubold
Posts: 5
Joined: Mon Sep 06, 2010 9:18 am
Location: Wroclaw, Poland

Re: ThinkPad T400 LCD not illuminated (no backlight)

#5 Post by hubold » Thu Nov 22, 2012 2:55 pm

Hi,

@oliversl, have you reseated your inverter ?

I've got the same problem as you and i do not know what to change, the inverter or cable.

P.S How can i check what type of backlight do i have ? It's lcd.
P.S 2 What does these numbers mean (6475-CTO, 21x, 22x) ?

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#6 Post by oliversl » Thu Nov 22, 2012 3:41 pm

Will try that first! Thanks

Oliver
hubold wrote:Hi,

@oliversl, have you reseated your inverter ?

I've got the same problem as you and i do not know what to change, the inverter or cable.

P.S How can i check what type of backlight do i have ? It's lcd.
P.S 2 What does these numbers mean (6475-CTO, 21x, 22x) ?
http://tinymailto.com/oliversl <-- my email after a captcha

hubold
Posts: 5
Joined: Mon Sep 06, 2010 9:18 am
Location: Wroclaw, Poland

Re: ThinkPad T400 LCD not illuminated (no backlight)

#7 Post by hubold » Mon Nov 26, 2012 6:37 pm

How its working ?

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#8 Post by oliversl » Wed Nov 28, 2012 1:07 am

The T400 may be in warranty, so I stopped just before opening the screen. Will report back in about a week.
http://tinymailto.com/oliversl <-- my email after a captcha

hubold
Posts: 5
Joined: Mon Sep 06, 2010 9:18 am
Location: Wroclaw, Poland

Re: ThinkPad T400 LCD not illuminated (no backlight)

#9 Post by hubold » Sun Dec 02, 2012 8:48 am

I've bought an inverter. I'm wondering if inverter is bad or smth in my computer is bad , becouse its not working with this other one inverter. Got some idea ? Anyone ?

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#10 Post by oliversl » Thu Dec 06, 2012 4:48 pm

I have done the resetting and still no backlight.

Will try to test with another inverter from another T400. If that works, then I will buy the inverter. The PN is:
FRU PN 42W8231

Any link for buying Lenovo parts?

Thanks
Oliver
hubold wrote:I've bought an inverter. I'm wondering if inverter is bad or smth in my computer is bad , becouse its not working with this other one inverter. Got some idea ? Anyone ?
http://tinymailto.com/oliversl <-- my email after a captcha

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#11 Post by oliversl » Fri Dec 07, 2012 3:54 pm

Can you see the image on the screen? but without backlight? Where did you buy the inverter? Thanks
Oliver
hubold wrote:I've bought an inverter. I'm wondering if inverter is bad or smth in my computer is bad , becouse its not working with this other one inverter. Got some idea ? Anyone ?
http://tinymailto.com/oliversl <-- my email after a captcha

hubold
Posts: 5
Joined: Mon Sep 06, 2010 9:18 am
Location: Wroclaw, Poland

Re: ThinkPad T400 LCD not illuminated (no backlight)

#12 Post by hubold » Mon Dec 10, 2012 11:35 am

I can barely see. I bought the inverter on the web site like an ebay but polish one.

RealBlackStuff
Admin
Admin
Posts: 19313
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: ThinkPad T400 LCD not illuminated (no backlight)

#13 Post by RealBlackStuff » Wed Dec 26, 2012 1:36 pm

If there is no backlight, you have a few options:
1) the backlight-fuse on the motherboard is faulty (happens sometimes)
2) the inverter is faulty (rarely)
3) the CCFL-tube is faulty or broken/burnt through (most often the problem).
Any reddish tint of the screen before this happened?
CCFL can be replaced (or replace the LCD-panel itself, or replace the complete lid)
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

underclocker
Moderator
Moderator
Posts: 4016
Joined: Wed Mar 23, 2005 3:52 pm
Location: Wash., D.C.

Re: ThinkPad T400 LCD not illuminated (no backlight)

#14 Post by underclocker » Wed Dec 26, 2012 1:56 pm

1) the backlight-fuse on the motherboard is faulty (happens sometimes)
I had an LED LCD T400 with this issue, sounds like the OP's issue, too. I had to replace the mobo. That was after trying a brand new LED LCD!
T510, i7-620m, NVidia, HD+, 8GB, 180GB Intel Pro 1500 SSD, Webcam, BT, FPR Home
T400s, C2D SP9400, Intel 4500MHD, WXGA+, 8GB, 160GB Intel X18-M G2 SSD, Webcam, BT, FPR Travel
Edge 14 Core i5 | Edge 15 Core i3 | Edge 15 Athlon II

richk
Moderator
Moderator
Posts: 2913
Joined: Sun Jan 01, 2006 3:29 pm
Location: San Francisco, CA

Re: ThinkPad T400 LCD not illuminated (no backlight)

#15 Post by richk » Sat Dec 29, 2012 6:40 pm

The fuse is more likely to blow on LED backlights because there is no inverter. The screen runs off DC which goes direct from the motherboard. With CCFL backlight, the inverter (converts DC to AC) blows. Sometimes, it is a fuse on the inverter, but they are cheap enough that it isn't worth changing.

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#16 Post by oliversl » Wed Feb 27, 2013 7:08 pm

Well, I bought the:
FRU PN 42W8231

and the problem is not solved. Should I buy a new LCD screen or could it be something on the motherboard.

I experienced not reddish color before failing.

Thanks
Oliver
oliversl wrote:I have done the resetting and still no backlight.

Will try to test with another inverter from another T400. If that works, then I will buy the inverter. The PN is:
FRU PN 42W8231

Any link for buying Lenovo parts?

Thanks
Oliver
http://tinymailto.com/oliversl <-- my email after a captcha

jayton4
Senior Member
Senior Member
Posts: 618
Joined: Mon Dec 12, 2011 9:00 am
Location: United States

Re: ThinkPad T400 LCD not illuminated (no backlight)

#17 Post by jayton4 » Wed Feb 27, 2013 10:41 pm

oliversl wrote:Well, I bought the:
FRU PN 42W8231

and the problem is not solved. Should I buy a new LCD screen or could it be something on the motherboard.

I experienced not reddish color before failing.

Thanks
Oliver
That would be my next step if it were me. Screens are pretty cheap on ebay here in the U.S. It might cost a little more to ship one down there to paradise.
jayton4
Current models/upgrades:
T410 2518X01- 8GB, Corsair Force GT 120GB
T410s 2901A3U- 8GB, Intel 6300 WiFi, Crucial m4 mSATA 256GB SSD w/ microSATA adapter
T420s 4174PPU- 16GB, Intel 520-series 7mm 180GB SSD, Crucial M550 512GB mSATA SSD, Intel 6300 WiFi
and a few classics in storage

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#18 Post by oliversl » Mon Mar 04, 2013 1:48 pm

Thanks Jayton, will search for the part. If I only had the resources to enjoy the paradise ... :)

BTW, my LCD is FRU PN # 27R2412, made by Samsung.

Will search for that part on ebay, if anyone knows a good store I will apreciate it.

Regards,
Oliver
http://tinymailto.com/oliversl <-- my email after a captcha

Tony Chan
Junior Member
Junior Member
Posts: 369
Joined: Sat Oct 22, 2005 12:25 am
Location: Vancouver, BC Canada

Re: ThinkPad T400 LCD not illuminated (no backlight)

#19 Post by Tony Chan » Mon Mar 11, 2013 2:27 pm

underclocker wrote:I had an LED LCD T400 with this issue, sounds like the OP's issue, too. I had to replace the mobo. That was after trying a brand new LED LCD!
When having faulty backlight fuse on the motherboard, would I still get images when connected to a external monitor?

I'm trying to help my friend fixing his T400 which has exact problem :
1. Black screen.
2. green LED indicators does not work except for wifi.
3. When plug in an external monitor, I can see the screen ( which, I think, tells me that video card is working ).

This narrows down to the LED panel ( or just the backlight ), or blown fuse I guess.

richk
Moderator
Moderator
Posts: 2913
Joined: Sun Jan 01, 2006 3:29 pm
Location: San Francisco, CA

Re: ThinkPad T400 LCD not illuminated (no backlight)

#20 Post by richk » Mon Mar 11, 2013 6:15 pm

With a blown fuse, an external monitor would work fine. Your symptoms would be no backlight on the LCD and often missing indicators on the bottom of the screen, depending on whether you have one or two fuses out.

jayton4
Senior Member
Senior Member
Posts: 618
Joined: Mon Dec 12, 2011 9:00 am
Location: United States

Re: ThinkPad T400 LCD not illuminated (no backlight)

#21 Post by jayton4 » Mon Mar 11, 2013 6:30 pm

Tony Chan wrote: This narrows down to the LED panel ( or just the backlight ), or blown fuse I guess.
I would add a loose cable to the list of possibilities in your situation. Are you using Windows as your OS? While connected to the external monitor, do the display properties allow you to extend to both displays or is the external display the only one that it registers?
jayton4
Current models/upgrades:
T410 2518X01- 8GB, Corsair Force GT 120GB
T410s 2901A3U- 8GB, Intel 6300 WiFi, Crucial m4 mSATA 256GB SSD w/ microSATA adapter
T420s 4174PPU- 16GB, Intel 520-series 7mm 180GB SSD, Crucial M550 512GB mSATA SSD, Intel 6300 WiFi
and a few classics in storage

Tony Chan
Junior Member
Junior Member
Posts: 369
Joined: Sat Oct 22, 2005 12:25 am
Location: Vancouver, BC Canada

Re: ThinkPad T400 LCD not illuminated (no backlight)

#22 Post by Tony Chan » Mon Mar 11, 2013 7:29 pm

richk wrote:With a blown fuse, an external monitor would work fine. Your symptoms would be no backlight on the LCD and often missing indicators on the bottom of the screen, depending on whether you have one or two fuses out.
That seems to be the exact sympton.
jayton4 wrote:I would add a loose cable to the list of possibilities in your situation. Are you using Windows as your OS? While connected to the external monitor, do the display properties allow you to extend to both displays or is the external display the only one that it registers?
I just connected a external monitor and only 1 display option ( the external monitor I just connected ) show up. What does this mean? that I might have a loose cable?

Btw, thanks for the quick responses. Really appreciated.

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#23 Post by oliversl » Thu Mar 14, 2013 9:37 am

Just an update from my part. I managed to get an authorized technical support to take a look a the T400.

They say they need to replace: LCD screen, LCD cable and motherboard. So, I don't know exactly what failed and why, but since they are changing the motherboard, I think my problem was the fuse on the motherboard Tony told us about.

HTH
Oliver
http://tinymailto.com/oliversl <-- my email after a captcha

jayton4
Senior Member
Senior Member
Posts: 618
Joined: Mon Dec 12, 2011 9:00 am
Location: United States

Re: ThinkPad T400 LCD not illuminated (no backlight)

#24 Post by jayton4 » Thu Mar 14, 2013 8:06 pm

It was under warranty?
jayton4
Current models/upgrades:
T410 2518X01- 8GB, Corsair Force GT 120GB
T410s 2901A3U- 8GB, Intel 6300 WiFi, Crucial m4 mSATA 256GB SSD w/ microSATA adapter
T420s 4174PPU- 16GB, Intel 520-series 7mm 180GB SSD, Crucial M550 512GB mSATA SSD, Intel 6300 WiFi
and a few classics in storage

Tony Chan
Junior Member
Junior Member
Posts: 369
Joined: Sat Oct 22, 2005 12:25 am
Location: Vancouver, BC Canada

Re: ThinkPad T400 LCD not illuminated (no backlight)

#25 Post by Tony Chan » Fri Mar 15, 2013 1:07 am

Warranty just expired for few months.

Was under 3years onsite and motherboard was changed onsite a year ago because of shot usb port.

The technician disassemble the laptop, swapped the motherboard, and re-assembled everything within 45 minutes!

This really doesn't sound good. Oliver, did you see only one monitor when you have blank screen?

oliversl
Freshman Member
Posts: 76
Joined: Thu Apr 17, 2008 1:19 pm
Location: San Jose, Costa Rica

Re: ThinkPad T400 LCD not illuminated (no backlight)

#26 Post by oliversl » Fri Mar 15, 2013 9:42 am

Hi Tony,
the T400 works perfect, no problem other than "no backlight on LCD" and "no green LEDs under the LCD".

Regards,
Oliver

Tony Chan wrote:Warranty just expired for few months.

Was under 3years onsite and motherboard was changed onsite a year ago because of shot usb port.

The technician disassemble the laptop, swapped the motherboard, and re-assembled everything within 45 minutes!

This really doesn't sound good. Oliver, did you see only one monitor when you have blank screen?
http://tinymailto.com/oliversl <-- my email after a captcha

Qassem
Posts: 3
Joined: Sun Aug 11, 2013 4:15 pm
Location: baghdad,iraq

Re: ThinkPad T400 LCD not illuminated (no backlight)

#27 Post by Qassem » Sun Aug 11, 2013 4:28 pm

hi friends

I have same problem in my laptop type lenovo R400
it is work normal but the backlight it is not work
led under the LCD not work except bluetooth led

if you have help to solve this problem

thanks
Last edited by Qassem on Sun Aug 11, 2013 4:34 pm, edited 1 time in total.

Qassem
Posts: 3
Joined: Sun Aug 11, 2013 4:15 pm
Location: baghdad,iraq

Re: ThinkPad T400 LCD not illuminated (no backlight)

#28 Post by Qassem » Sun Aug 11, 2013 4:33 pm

hi friends

I have same problem in my laptop type lenovo R400
it is work normal but the backlight it is not work
led under the LCD not work except bluetooth led

if you have help to solve this problem

thanks

richk
Moderator
Moderator
Posts: 2913
Joined: Sun Jan 01, 2006 3:29 pm
Location: San Francisco, CA

Re: ThinkPad T400 LCD not illuminated (no backlight)

#29 Post by richk » Mon Aug 12, 2013 3:39 pm

With the Bluetooth light working and no others, I assume 1 or 2 blown fuses on the motherboard. (They are near the LCD connector. There is a larger one with a "P" on it, and a smaller one that usually has an "F" on it.

aaqpublic
Posts: 2
Joined: Mon Apr 16, 2012 4:48 am
Location: Kajang, Selangor, Malaysia

Solved: No backlight no indicator lights except wifi

#30 Post by aaqpublic » Fri Apr 18, 2014 2:57 pm

Had the same problem and it's solved now. I found the solution somewhere else and I couldn't locate the same now, so I'll add my screenshots and case now
In this case, the lcd backlight and indicator lights are not working, except the wifi led (leftmost the indicator lights row), if you connect your laptop to an external monitor you'll have an output.
The problem here is that no power is reaching the display section, usually for one of two reasons:
* Either the LCD cable is damaged (the power line(s) of the cable connecting the mobo to the LCD are cut), this case you'll need to replace the cable (my LCD cable model is 93P4593, it's similar to the one in http://goo.gl/iQ9Ze9).
* Or it's just a fuse that needs to be replaced or jumped, this was the problem of my T400. Here's what I did:
1) Remove the palmrest and keyboard
2) locate the display cable connection to the motherboard (mobo), you'll need to remove one screw which fixes the cable to the mobo.
3) locate the two fuses, marked in red ellipses in the following image. The fuses are very tiny, their lengths are around 1.5ml and 0.5ml, found just under the aluminium chassis/frame. The photo is taken from above the screen which was laid back 180 degrees.
Image
4) Replace (safer, but needs an expert service) or jump (as a last solution) the fuses. I jumped them using a "conductive wire glue", like the one found in http://goo.gl/VFQBsz. The fuses are not so easy to access, I used the needle provided with the conductive wire glue syringe. Here's the result:
Image
5) Assembled everything, waited 8 hours to make sure the glue dried, switched on my laptop and the LCD and leds were totally working.
Hope this helps somebody out there.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 8 guests