Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T420s won't power off anymore

T400/T410/T420 and T500/T510/T520 series specific matters only
Post Reply
Message
Author
ruudb
Posts: 1
Joined: Fri Apr 10, 2020 4:45 am
Location: Roelofarendsveen, NL

T420s won't power off anymore

#1 Post by ruudb » Fri Apr 10, 2020 5:36 am

I'm new here. I was a lurker for years, finding information on maintaining my thinkpads although I have a lot of problems with them. Until now.....

I've got a T420s for years. It's my main PC. I've upgraded it many times (1080p, SSD, 16GB..) and I'm currently using it for working at home. I'm using the minidock a lot. I dock/undock twice a day and perhaps that's the cause of my problem I've got now.

BTW: I already ruled out: broken cmos-battery, broken powerswitch (swapped keyboard already), broken battery. They all work fine. And I already tried all combinations of powering on/off with/without battery/power cord, docked/undocked..

These are the symptoms:

- I can't switch off my laptop with the power button. Even when I keep pressing it half minute.
- When I send an ACPI poweroff in software it shutdows down like it should, the power button led switches off and immediately after that it switches on again.
- I have to remove the powercord and the battery to switch it off.
- When I insert the battery again it does not switch on automatically; I can start it with the power button.

As said, it all started after a couple of days working with the Mini dock. I'm afraid I shortcutted something in the connector at the bottom of my laptop. I tried to clean it with compressed air.

Any ideas? Can I disconnect the dock connector somehow? I can live without a docking station. But I get tired of removing the batterypack in order to shutdown my laptop and I can't live without a thinkpad :-)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/T410/T420 and T500/T510/T520 Series”

Who is online

Users browsing this forum: No registered users and 24 guests