Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T420 works on battery but not using PSU

T400/T410/T420 and T500/T510/T520 Series
Post Reply
Message
Author
g8tzl2004
Posts: 21
Joined: Sun Nov 01, 2020 9:11 pm
Location: Hereford, United Kingdom

T420 works on battery but not using PSU

#1 Post by g8tzl2004 » Tue Nov 24, 2020 3:37 pm

I have a T420 in my collection which works using a battery charged in another T420 BUT does not work using the power supply.

When the power supply is plugged into the T420 the green LED lights briefly...but the battery is not charged (although the battery charges OK in another laptop) and the laptop will not boot up if the battery is empty.

Any ideas? I was thinking that it might be an internal motherboard fuse? But the green LED flashes briefly. Maybe the "power management" module is faulty?

Thanks

rkawakami
Admin
Admin
Posts: 10289
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: T420 works on battery but not using PSU

#2 Post by rkawakami » Tue Nov 24, 2020 9:09 pm

If you can verify that the PSU works with another Thinkpad, then that indeed points to the problem being on the T420 motherboard. I'd say the fuse is good (LED briefly flashes) but something else in the power controller circuitry is broken.
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

g8tzl2004
Posts: 21
Joined: Sun Nov 01, 2020 9:11 pm
Location: Hereford, United Kingdom

Re: T420 works on battery but not using PSU

#3 Post by g8tzl2004 » Wed Nov 25, 2020 4:18 pm

Thanks for the reply.

PSU is good.

Any idea of typical faults with the power management circuit? Dry joints or failed components? Is the power management a separate PCB or is it part of the motherboard? Is the power management IC easy to replace? Maybe its damage to a PCB track. If the original owner used a wrong PSU (ie too high a voltage) would that blow a fuse or burn out a track or blow the PM IC? The problem I am having appears to be uncommon??

rkawakami
Admin
Admin
Posts: 10289
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: T420 works on battery but not using PSU

#4 Post by rkawakami » Wed Nov 25, 2020 7:40 pm

I'd say high on the list of things to look for would be:
  • blown MOSFET(s)
  • leaky/shorted electrolytic capacitor(s)
  • bad voltage controller
I don't know about how common/uncommon your issue is for the T420. Early T2x systems have what's called the "Blink of Death". Basically when you press the power button, the power LED flashes and that's it. Sometimes when you press the button, the laptop will power up correctly. I've been away from Thinkpads lately but I believe that problem is with the power controller not seeing the proper signal (voltage). It could be similar to your issue or it could be something else.
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

g8tzl2004
Posts: 21
Joined: Sun Nov 01, 2020 9:11 pm
Location: Hereford, United Kingdom

Re: T420 works on battery but not using PSU

#5 Post by g8tzl2004 » Thu Nov 26, 2020 10:27 am

Thanks for the very useful list of things to look for.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/T410/T420 and T500/T510/T520 Series”

Who is online

Users browsing this forum: regenwald343424 and 12 guests