Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

R500 and Windows 8.1

R400/R500 series specific matters only
Post Reply
Message
Author
Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

R500 and Windows 8.1

#1 Post by Bellzemos » Sun Jan 17, 2016 6:13 am

Hi!

I'll probably buy a used R500 with 4 GB RAM and am planning to install Windows 8.1 on it.

Has anyone had luck installing Windows 8.1 x64 on a R500? Will everything function properly? There are no drivers for Windows 8.1 available on the Lenovo R500 support site, only programs/utilities.

So, what is your experience with it?

Thank you!

thinkpadcollection
Senior Member
Senior Member
Posts: 805
Joined: Fri Oct 17, 2014 8:13 pm
Location: kingston, ontario, Canada

Re: R500 and Windows 8.1

#2 Post by thinkpadcollection » Sun Jan 17, 2016 4:38 pm

Get 2Rx8 DDR3-1333 pair (2x 4GB) memory. Micron, elpida and samsung from ebay. Make sure this is 1.5V. Not DDR3L or 1.35V.

Cheers, Jason

Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

Re: R500 and Windows 8.1

#3 Post by Bellzemos » Mon Jan 18, 2016 11:55 am

Hello, Jason! Thank you for your reply but I'm asking about Thinkpad R500 and Windows 8.1 compatibility, not RAM upgrade.

thinkpadcollection
Senior Member
Senior Member
Posts: 805
Joined: Fri Oct 17, 2014 8:13 pm
Location: kingston, ontario, Canada

Re: R500 and Windows 8.1

#4 Post by thinkpadcollection » Mon Jan 18, 2016 4:30 pm

I'm interested in windows 7 and 10, as 8/8.1 is a horrible OS in GUI ergonomics usability interface. Sorry.

Cheers, thinkpadcollection

Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

Re: R500 and Windows 8.1

#5 Post by Bellzemos » Wed Jan 20, 2016 4:06 pm

I use Classic Shell to change the appearance of Windows 8.1 to look more like 7 or XP.

Windows 8.1 is snappier, works a bit faster on older PCs than Windows 7, that's why I'd like to make it work on the old R500.

Anyone had any luck with it?

Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

Re: R500 and Windows 8.1

#6 Post by Bellzemos » Fri Jan 22, 2016 6:07 pm

I installed Windows 8.1 x64 on the R500 successfully. I used some Windows 7 drivers and they were accepted.

The only two drivers that won't work are the Fingerprint reader driver and the Display driver (Intel Graphics Media Accelerator 4500MHD - GMA 4500MHD).

How can I get them to work, or, better - where can I get a compatible Windows 8 drivers for those two devices?

hhhd1
Junior Member
Junior Member
Posts: 499
Joined: Mon Nov 17, 2014 7:23 pm
Location: Cairo, Egypt

Re: R500 and Windows 8.1

#7 Post by hhhd1 » Fri Jan 22, 2016 6:53 pm

the drivers for the gfx should be available either via Intel website, or should be available in windows update, or both.

if you have allowed your computer to look for drivers updates, go to device manager, and select the graphics adapter, and let it search online from there.

edit:

try this too:
https://communities.intel.com/thread/51 ... 0&tstart=0

and to verify that it is working, trying running 'furmark' for few seconds to verify that there is graphics drivers working
===

Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

Re: R500 and Windows 8.1

#8 Post by Bellzemos » Sat Jan 23, 2016 1:29 pm

I tried installing the driver from the link (Intel) and it won't work. I tried Windows update and it didn't install anything.

A Microsoft driver was installed with the Windows installation itself though and the native resolution of the monitor is displayed (1280x800).

Should that driver be good enough? I still have a question mark under "other devices" on the "Display Driver" though...

hhhd1
Junior Member
Junior Member
Posts: 499
Joined: Mon Nov 17, 2014 7:23 pm
Location: Cairo, Egypt

Re: R500 and Windows 8.1

#9 Post by hhhd1 » Sat Jan 23, 2016 3:47 pm

Bellzemos wrote:Should that driver be good enough? I still have a question mark under "other devices" on the "Display Driver" though...
maybe yes,
hhhd1 wrote: trying running 'furmark' for few seconds to verify that there is graphics drivers working
===

Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

Re: R500 and Windows 8.1

#10 Post by Bellzemos » Sat Jan 23, 2016 5:48 pm

I never used Furmark before, can I damage the GPU doing it? How do I do the thes and how will I know if the driver is working or not?

All I did was I tried watching a Youtube 720p video and it played fine.

hhhd1
Junior Member
Junior Member
Posts: 499
Joined: Mon Nov 17, 2014 7:23 pm
Location: Cairo, Egypt

Re: R500 and Windows 8.1

#11 Post by hhhd1 » Sat Jan 23, 2016 8:09 pm

furmark is a tool to stress test GPUs, afaik, it is normal to expect high load from many games anyway.

running it for few seconds should be fairly safe, just to see it working and not complaining about the non-existence of the GPU.

if you can play 720p videos, and the resolution is correct,
AND brightness control buttons are working, and you can sleep and hibernate properly,
then the graphics drivers installed now are most likely enough.
===

Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

Re: R500 and Windows 8.1

#12 Post by Bellzemos » Sun Jan 24, 2016 5:28 am

I installed Furmark and when I tried to run the test it displayed this:
http://shrani.si/f/1K/EF/2fYORsTD/furmark.jpg

Does that mean that it can only test nVidia and ATI/AMD GPUs or is it not detecting my GPU?


I then installed GPU-Z and it displayed this:
http://shrani.si/f/s/5R/3iTzK5Cw/gpuz.jpg


I am able to hibernate but not sleep:
http://shrani.si/f/2z/2S/4bBIvcyh/power.jpg

I can play 720p Youtube videos, the resolution is correct and the brightness control works.


This is how the Device Manager looks like:
http://shrani.si/f/m/Sj/23JDCbt8/devman.jpg

I disabled the fingerprint reader in the BIOS so now it's not showing as missing anymore (I won't be using it anyway).

I have my doubts about using the full potential of the GPU though, because of the missing Video Controller driver that is seen (I have disabled the device since I can't stand the question mark/missing driver :P).

If I look at the properties of the MS Basic Display Adapter it shows a driver from 2006...

I would like to keep using Windows 8.1 x64 and not go back to Windows 7 x64 but only if I will not experience any future problems regarding the missing GPU driver.

What do you think?

Also, thank you! :)

Bellzemos
Posts: 16
Joined: Thu Nov 28, 2013 11:17 pm
Location: Ljubljana, Slovenia

Re: R500 and Windows 8.1

#13 Post by Bellzemos » Sun Jan 24, 2016 3:29 pm

Epilogue (hopefully :))

I tried this:
http://tachisalopex.blogspot.si/2012/04 ... river.html

And it worked.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad R400/R500 Series”

Who is online

Users browsing this forum: No registered users and 4 guests