Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Access denied though I am the administrator. W530

W500/510/520 and W700/710 series specific matters only
Post Reply
Message
Author
khary23
Freshman Member
Posts: 56
Joined: Tue Jun 19, 2007 3:26 pm
Location: Broooklyn,NY

Access denied though I am the administrator. W530

#1 Post by khary23 » Tue Oct 22, 2019 9:43 am

last night I changed the account permissions of one of the authenticate users accounts , now I cannot make any changes from my account though it says that I am an administrator and should have full access. I really need help with this as my Masters research needs to be accessible to me.

khary23
Freshman Member
Posts: 56
Joined: Tue Jun 19, 2007 3:26 pm
Location: Broooklyn,NY

Re: Access denied though I am the administrator. W530

#2 Post by khary23 » Tue Oct 22, 2019 10:09 am

Just noticed that the owner of C: had some how been changed to Authenticated Users. I tried to change it back to my account with the change function but get a cannot open access to control editor access denied a message.

khary23
Freshman Member
Posts: 56
Joined: Tue Jun 19, 2007 3:26 pm
Location: Broooklyn,NY

Re: Access denied though I am the administrator. W530

#3 Post by khary23 » Tue Oct 22, 2019 10:25 am

Fixed it.

MikalE
ThinkPadder
ThinkPadder
Posts: 1062
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: Access denied though I am the administrator. W530

#4 Post by MikalE » Tue Oct 22, 2019 10:27 am

I hope your Masters research isn't in computer science...
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7 4242-4UU(CTO)


T520: i7-2760QM(2.40GHz),16GB, 500GB SSD/250GB SSD, 1600x900, 1GB NVIDIA, DVDRW, Smartcard, media card, FPR, Win7 Pro64, XP Pro64 whitelist BIOS, N 6300 AGN, German KB, BT 4.0.

JPOESQ
**SENIOR** Member
**SENIOR** Member
Posts: 180
Joined: Sun May 16, 2004 2:26 pm
Location: San Francisco, CA
Contact:

Re: Access denied though I am the administrator. W530

#5 Post by JPOESQ » Thu Oct 24, 2019 7:19 pm

khary23 wrote:
Tue Oct 22, 2019 10:25 am
Fixed it.
Since many people who peruse this forum might run into the same problem and not be as successful as you, perhaps you could share your fix.
John P. O'Banion, JD, PE, BSEE
Registered Patent Attorney
http://www.intellectual.com

600, X220, T530, X1 Carbon 5th Signature Edition

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20408
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Access denied though I am the administrator. W530

#6 Post by RealBlackStuff » Fri Oct 25, 2019 1:41 am

I found a way around most of these obstacles by "Taking Ownership" of HD contents.
Been using this for donkeys years!

You can either go the long, convoluted way around, using e.g. this: https://www.windowscentral.com/how-take ... windows-10

Or apply just this small mod to your Registry:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Take Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Take Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
Copy the above and paste it into a file: InstallTakeOwnership.reg in a safe place.
Right-click on that .reg file and select: Merge to add it to your registry.
From now on you can right-click on ANYthing you want and select Take Ownership!
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

Shredder11
Junior Member
Junior Member
Posts: 327
Joined: Sat Jun 30, 2012 6:25 pm
Location: Bradford, West Yorkshire, England

Re: Access denied though I am the administrator. W530

#7 Post by Shredder11 » Fri Oct 25, 2019 4:17 pm

Thanks for the reg file. Does this work in any version of Windows from say XP upwards?
Z61p x3 (C2D T7600, 3GB, 500GB SSD, BCM70015, Advanced Dock x1, Mini Dock x2)
W520 (C2Q i7-2720QM, 8GB, 60GB SSD)
X61 (C2D T7500, 3GB, 250GB SSD, BCM70015)
X61s (2GB, 120GB SSD)
T43p (P M 760, 2GB, IBM Port Replicator II)
G41 (P4 3.46GHz, 2GB, 40GB)

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20408
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Access denied though I am the administrator. W530

#8 Post by RealBlackStuff » Sat Oct 26, 2019 1:40 am

From my own experience it works perfect in XP, Vista, W7 and W8/W8.1
In all cases I am/was the Administrator, but I assume for a 'standard' user it'll work the same.
I don't have (or want) W10, so don't know that.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

dr_st
Moderator
Moderator
Posts: 8121
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: Access denied though I am the administrator. W530

#9 Post by dr_st » Sat Oct 26, 2019 3:11 am

You have to be careful with taking ownership, though. If you take ownership of too many system files that are used by special built-in accounts (e.g., System, TrustedInstaller), various things can break in unpredictable ways. Sometimes you'll only notice it much later.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

MikalE
ThinkPadder
ThinkPadder
Posts: 1062
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: Access denied though I am the administrator. W530

#10 Post by MikalE » Sat Oct 26, 2019 4:44 am

What causes things to break because of ownership?
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7 4242-4UU(CTO)


T520: i7-2760QM(2.40GHz),16GB, 500GB SSD/250GB SSD, 1600x900, 1GB NVIDIA, DVDRW, Smartcard, media card, FPR, Win7 Pro64, XP Pro64 whitelist BIOS, N 6300 AGN, German KB, BT 4.0.

dr_st
Moderator
Moderator
Posts: 8121
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: Access denied though I am the administrator. W530

#11 Post by dr_st » Sat Oct 26, 2019 8:05 am

Without knowing Windows internals, I can just assume that the same way you can get "permission denied" because you are not the owner, then if you take ownership, and later a system account tries to do something with the file, it will too get a "permission denied", and things will not work as expected.

Not saying that sometimes it is not the correct solution (especially if we are talking about your files that somehow got the ownership assigned wrong), but it should not be used too frivolously on system files.

It happened to me once before with ownership change breaking some softlinks within AppData folder hierarchy - they would not get resolved correctly ending in infinite directory loops, or something along those lines.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

MikalE
ThinkPadder
ThinkPadder
Posts: 1062
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: Access denied though I am the administrator. W530

#12 Post by MikalE » Sat Oct 26, 2019 10:20 am

Thank you for the explanation. It makes perfect sense.
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7 4242-4UU(CTO)


T520: i7-2760QM(2.40GHz),16GB, 500GB SSD/250GB SSD, 1600x900, 1GB NVIDIA, DVDRW, Smartcard, media card, FPR, Win7 Pro64, XP Pro64 whitelist BIOS, N 6300 AGN, German KB, BT 4.0.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/510/520 and W7x0 Series”

Who is online

Users browsing this forum: No registered users and 6 guests