R30 IRQ error

R, A, G and Z series specific matters only
Post Reply
Message
Author
wujstefan
Junior Member
Junior Member
Posts: 442
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

R30 IRQ error

#1 Post by wujstefan » Fri Feb 24, 2017 3:25 pm

Hello,

Working on another vintage project.
I've got a nice R30 in stock - however, when trying to boot it I get two errors:

ERROR
Warning: IRQ not configured - PCI
Bus: 00 Device: 13 Function:00
ERROR
Warning: IRQ not configured - PCI
Bus: 00 Device: 0A Function:00

Tried to set "auto-detect" on PCI devices in BIOS, but without success. After setting such thing I've got a stuck, black screen.

EDIT:
Disabling 2nd PCI device in BIOS causes helps with one error.
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

theterminator93
Senior Member
Senior Member
Posts: 864
Joined: Fri Oct 11, 2013 7:45 pm
Location: Avon Lake, Ohio, United States

Re: R30 IRQ error

#2 Post by theterminator93 » Fri Feb 24, 2017 8:45 pm

What devices are installed in the CSC and mPCI slots?
Daily: T25 | W520 i7-2860QM·Quadro 2000m·IPS FHD | T420 i7-2640M·NVS 4200m·IPS FHD | X220 i7-2640M | T601F T9900·NVS 140M·IPS UXGA
Wife's: T61p T9500·2010 FX570m·WUXGA | X220T i7-2640M
Others: T61p·61·43·42p|X41T·24·23·22|G41|A31p·22m|i1200|TransNote|380D|365XD|701C|755C

wujstefan
Junior Member
Junior Member
Posts: 442
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: R30 IRQ error

#3 Post by wujstefan » Sat Feb 25, 2017 4:26 pm

Can't remember now, need to disassemble the unit to find out. Will get back tomorrow.

I think it's CMOS battery is dead as well.
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

wujstefan
Junior Member
Junior Member
Posts: 442
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: R30 IRQ error

#4 Post by wujstefan » Mon Feb 27, 2017 3:26 pm

I've got a modem daughter card in CDC slot.
mPCI is empty.
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

theterminator93
Senior Member
Senior Member
Posts: 864
Joined: Fri Oct 11, 2013 7:45 pm
Location: Avon Lake, Ohio, United States

Re: R30 IRQ error

#5 Post by theterminator93 » Mon Feb 27, 2017 5:04 pm

Hm... Does removing the card cause the error to go away?
Daily: T25 | W520 i7-2860QM·Quadro 2000m·IPS FHD | T420 i7-2640M·NVS 4200m·IPS FHD | X220 i7-2640M | T601F T9900·NVS 140M·IPS UXGA
Wife's: T61p T9500·2010 FX570m·WUXGA | X220T i7-2640M
Others: T61p·61·43·42p|X41T·24·23·22|G41|A31p·22m|i1200|TransNote|380D|365XD|701C|755C

wujstefan
Junior Member
Junior Member
Posts: 442
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: R30 IRQ error

#6 Post by wujstefan » Wed Mar 01, 2017 3:43 pm

Nope.
However, when in bios - config - pci I made a change to two devices.
Disabling 4th PCI IRQ removed the first issue.
Changing anything in 2nd PCI IRQ makes the system to lag-blank screen directly after displaying the thinkpad-start logo.
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

theterminator93
Senior Member
Senior Member
Posts: 864
Joined: Fri Oct 11, 2013 7:45 pm
Location: Avon Lake, Ohio, United States

Re: R30 IRQ error

#7 Post by theterminator93 » Wed Mar 01, 2017 9:14 pm

With a dead CMOS battery... clearing CMOS is probably perpetual. With a new CMOS battery, is there any effect?

Hmm. I'm at my wit's end, I'll have to admit.
Daily: T25 | W520 i7-2860QM·Quadro 2000m·IPS FHD | T420 i7-2640M·NVS 4200m·IPS FHD | X220 i7-2640M | T601F T9900·NVS 140M·IPS UXGA
Wife's: T61p T9500·2010 FX570m·WUXGA | X220T i7-2640M
Others: T61p·61·43·42p|X41T·24·23·22|G41|A31p·22m|i1200|TransNote|380D|365XD|701C|755C

wujstefan
Junior Member
Junior Member
Posts: 442
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: R30 IRQ error

#8 Post by wujstefan » Fri Mar 03, 2017 12:54 pm

I've reinstalled the CMOS battery. No effect. The system still hangs.
I'm losing hope really...

EDIT:
And directly after writing it, I've came to the solution!
Swapped the HDD. Set all the PCI IRQs at "11". And right now I'm at win98 installer window!
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad R, A, G and Z Series”

Who is online

Users browsing this forum: No registered users and 1 guest