Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

x120e fainting spells

X100e/X120e/X130e etc. series specific matters only.
Post Reply
Message
Author
l.butler
Posts: 33
Joined: Sat Oct 14, 2006 3:06 pm
Location: Central Michigan

x120e fainting spells

#1 Post by l.butler » Mon Jan 28, 2013 7:34 am

My wife bought an x120e a few (3?) years ago. It has been a bit of a disappointment to me, though not her, as the build quality does not seem to be up to the thinkpad standard. Anyhow...

In the last year, the machine has taken to doing a hard powerdown in the middle of some task. It does always powerup immediately, so I call this fainting. These attacks are usually when she is travelling and I am not with her; they have never happened at home under normal conditions.

I suspect they are heat-related, and when I ran memtest86+, the machine does faint after about 15mins from a cold boot. After that, it takes less than 1min...

Any thoughts on what this might be?

crawford
Posts: 2
Joined: Mon Jan 28, 2013 11:04 am
Location: toronto, canada

Re: x120e fainting spells

#2 Post by crawford » Tue Jan 29, 2013 9:13 pm

I have this on occasion as well...However I have narrowed it down to certain situations. It seems that whenever I am running full screen video, and unplug or plug in the AC it has that shutdown you are talking about.

I have heard that it may have to do with the dual core processor switching speeds and cores when the power-state changes. The system freaks out for some reason and shuts itself down to 'protect' the system

I have had those 'fainting spells' much less often after doing this:

-Uninstall the Thinkpad Power management program if you have it. Having Windows management and the Thinkpad software on at the same time seemed redundant. Especially since you MUST keep the Thinkpad Power Management Driver installed, otherwise Windows won't know how to handle your system and battery.

-Then go to the Windows 7 power management utility. You can find it by clicking the battery icon in the System Tray.

Choose More Power Options>choose Maximum performance>change plan settings>change advanced power settings>Processor Power Management
-Then, make sure whatever settings you choose are exactly the same for battery as they are for AC

I personally have set it this way:
minimum processor speed:50%
system cooling policy:passive
maximum processor state:100%

As well I set the ATI graphics Power settings the same on battery as for AC: maximum performance.

On another note, I rarely shut down my system completely. I always put it to Sleep when I'm not using it. A good friend of mine who is a hardware designer urged me to do that. He said that components don't like being completely turned off and on all the time, and that the system will be happier if you do it and will last longer for you. I especially like it too because I never have to wait for boot up, my comp is always ready to go, which is important when i'm dealing with clients and don't want to waste time.

Lastly, I avoid the fainting spells altogether now by only plugging in/out the ac when the Comp is awake and not running anything serious. Then the system has a chance to switch easily. I hope this helps!

Post Reply

Return to “ThinkPad X1xxe Series”

Who is online

Users browsing this forum: No registered users and 3 guests