Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Win 8.0 will not load because of "ataport.sys"

Windows 8 on ThinkPads
Post Reply
Message
Author
warp4dennis
Posts: 29
Joined: Sun Mar 23, 2014 8:11 am
Location: Sankt Augustin, Germany

Win 8.0 will not load because of "ataport.sys"

#1 Post by warp4dennis » Mon Jan 05, 2015 8:47 am

I installed Windows 7 on my T60 a few days ago. After making sure that it runs I then turned my attention to Windows 8.0.
When Win 8.0 tries to load I get this message "Driver IRQL not less or equal (ataport.sys). Windows couldn't load correctly."
Where do I go to download this piece of s/w? I found nothing on the Lenovo update page.

warp4dennis
Posts: 29
Joined: Sun Mar 23, 2014 8:11 am
Location: Sankt Augustin, Germany

Re: Win 8.0 will not load because of "ataport.sys"

#2 Post by warp4dennis » Thu Feb 05, 2015 8:28 am

This time around I did things differently.
Before, I started up Win 7 and then inserted the Win 8.0 disk and let the Win 8.0 setup run. After about an hour and and 20 minutes I get an ataport.sys error.
As an experiment I bypassed the Win 7 install process, and tried to boot up using the Win 8.0 disk.
My Laptop BIOS is set so the first drive checked is the CD/DVD drive.
That means when I turn on the ThinkPad I can select either the CD/DVD or the HDD in that order.
A note on the screen tells you to press any key if you want to run the CD/DVD drive.
In about 2 minutes, after selecting the CD/DVD, an error message comes up to tell you there is a problem with the installation. And you get basically the same error message as before: "The driver IRQL not less or equal (ataport.sys)" is there in the fine print.
Could the problem be with the Win 8.0 disk and not with the ThinkPad?

warp4dennis
Posts: 29
Joined: Sun Mar 23, 2014 8:11 am
Location: Sankt Augustin, Germany

Re: Win 8.0 will not load because of "ataport.sys"

#3 Post by warp4dennis » Fri Feb 20, 2015 12:19 pm

I found what the problem was. A driver needed to be updated. The driver that needed to be updated was the one for the Express Card Reader. Unfortunately that's not the name a person should use in looking for this driver.
The name that IBM//LENOVO uses is: Realtek PCIE Card Reader Driver
It consists of two files, and they are 8gx107ww.exe and g1ic09ww.exe.
One is for the PCMCIA Card Bus card reader and the other for the Express Card reader.
A test to see if you need these driver can be made by inserting a Card Bus card and an Express Card into their slots.
Then go to Start click on Computer and they both should show up as drives.
On my ThinkPad T60 the CardBus Card is Drive E: and the Express Card is Drive F:
If either one of your Cards do not show up in the Windows Explorer as a drive, than you need the driver(s).
Lenovo suggested that I use their "Chip Set" update, but I think that only one of the drivers was included with the package.
The "Realtek PCIE Card Reader Driver" I was not able to find on the Lenovo driver page.
It could be there somewhere, but as of this date I have only been able to find this driver on the Internet.

dr_st
Senior ThinkPadder
Senior ThinkPadder
Posts: 7247
Joined: Sat Oct 29, 2005 6:20 am

Re: Win 8.0 will not load because of "ataport.sys"

#4 Post by dr_st » Sun Feb 22, 2015 4:17 am

Thank you for the update. :thumbs-UP:

I recall you already posted something about this before, in this thread:
http://forum.thinkpads.com/viewtopic.php?f=57&t=116770

I believe you are mistaken about certain things, but perhaps it is me who is wrong. I would appreciate some clarifications, so that we don't end up posting misinformation here. :)
  1. The driver g1ic09ww.exe is the generic Intel chipset driver. The chipset does include support for the ExpressCard slot (which is wired to the chipset PCIe and chipset USB). Modern versions of Windows should pick up chipset support without you having to install this driver, although sometimes it may be necessary.
  2. The driver 8gx107ww.exe, which is the Realtek card reader driver appears to be a driver for a device you have plugged into the ExpressCard slot. It is not a driver for the ExpressCard itself. As far as I know, this card reader is not an integral part of any T60 system, and therefore it is not surprising there is no driver for it on the T60 driver page.
  3. The T60 CardBus driver (for the TI 1520) is ossa04ww.exe, which you did not mention. You did not install it, because it does not need to be installed. Support for the CardBus controller is built into any Windows XP and later. The driver is only needed for 98/ME/2000. None of the drivers you installed is a CardBus driver.
Current: Thinkpad 25 (20K7), Yoga 14 (20FY), X220 4291-4BG, T410 2537-R46, T60 2007-QPG, T42 2373-F7G
Collectibles: T430s (IPS FHD + Classic Keyboard), X32 (IPS Screen)
Retired: X61 7673-V2V, T60 1952-F76, A31p w/ Ultrabay Numpad

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 8”

Who is online

Users browsing this forum: No registered users and 3 guests