Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Cursors refuse to animate on ThinkPad X230

Windows 10 on Lenovo hardware
Post Reply
Message
Author
SurrealMustard
Freshman Member
Posts: 123
Joined: Fri May 01, 2015 8:50 pm
Location: The United States of America

Cursors refuse to animate on ThinkPad X230

#1 Post by SurrealMustard » Tue Aug 14, 2018 7:09 pm

I've been working with this new ThinkPad X230 and am pretty happy with where everything is at now. Unfortunately, I've encountered a weird bug where any of Windows's mouse pointers that should be animated (namely the "busy" and "working in background") are simply not animated. If I go into the pointer settings and switch to a different set of pointers, it'll work fine until the next time that TrackPoint scrolling is used. With a 768 pixel-tall display, I do a lot of scrolling. Has anyone ever seen this phenomenon before? If so, is there any advice from the community to allow animated mouse pointers and TrackPoint scrolling?

If it helps, the PC is on the latest (17134) build of Windows 10 and has the newest (19.0.17.135) UltraNav driver from Lenovo's website.

SurrealMustard
Freshman Member
Posts: 123
Joined: Fri May 01, 2015 8:50 pm
Location: The United States of America

Different model, Different OS, Different driver, same problem

#2 Post by SurrealMustard » Fri Oct 26, 2018 7:18 pm

Just to add another data point to this, I found that this seems to affect newer drivers as well. Driver version 19.3.4.214 on the fourth-generation X1 Carbon is doing the same exact thing, although it's not as big of a bother on there because it actually has a competent trackpad, reducing/eliminating the need to use the Trackpoint. I'm running the dreaded build 17763, so it doesn't appear to be limited to just one build of Windows 10, one specific version of the driver, or even one generation/model of computer.

How has this not been fixed yet?! Does anybody have any recommendations for a workaround? Or is it better to just avoid the Trackpoint?

w0qj
Senior Member
Senior Member
Posts: 758
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: Cursors refuse to animate on ThinkPad X230

#3 Post by w0qj » Sun Oct 28, 2018 7:48 am

I'm also using my X1C4 (X1 Carbon Generation 4) as my daily driver, albeit with Windows 7 64-bit.

Now that you eagle-eyed folks have noticed it, I can also confirm that my X1C4 under patched Windows 7 64-bit Windows's mouse pointers that should be animated (namely the "busy" and "working in background") are simply not animated.
Daily Driver: X1 Carbon 4th Gen (X1C4): i7 | 16GB | 1TB | IPS WQHD | LTE WWAN | Win7 Pro
Current Thinkpads: X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

TPFanatic
ThinkPadder
ThinkPadder
Posts: 1107
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: Cursors refuse to animate on ThinkPad X230

#4 Post by TPFanatic » Sun Oct 28, 2018 8:42 am

I noticed this at times in Windows 10, no idea what causes it or how to fix. It does what it wants. You can always just switch to the Windows Classic cursor which is what I use.
lenovo X230 i5 3320m IPS 8GB
lenovo T430 i5 3320m FHD 8GB
lenovo T500 P9700 WUXGA 8GB


Enable 2 finger scroll on any Synaptics touchpads with registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

SurrealMustard
Freshman Member
Posts: 123
Joined: Fri May 01, 2015 8:50 pm
Location: The United States of America

Thank you for the information; here's what we know

#5 Post by SurrealMustard » Mon Oct 29, 2018 6:54 pm

TPFanatic wrote:
Sun Oct 28, 2018 8:42 am
I noticed this at times in Windows 10, no idea what causes it or how to fix. It does what it wants. You can always just switch to the Windows Classic cursor which is what I use.
Thanks to this thread, we know exactly what causes it, which is first-use of the scroll button for the Trackpoint. The good news is that some of these machines are so fast that you'll hardly ever see that pointer long enough to notice. Otherwise, I don't consider the "classic" cursor to be an acceptable alternative. The modern implementation seen since the days of Vista is too entrenched in modern expectations for this to be an option for most folks, (myself definitely included) unfortunately.
w0qj wrote:
Sun Oct 28, 2018 7:48 am
I'm also using my X1C4 (X1 Carbon Generation 4) as my daily driver, albeit with Windows 7 64-bit.

Now that you eagle-eyed folks have noticed it, I can also confirm that my X1C4 under patched Windows 7 64-bit Windows's mouse pointers that should be animated (namely the "busy" and "working in background") are simply not animated.
That's definitely a useful datapoint. If you're seeing it on Windows 7, then it's probably more of a driver thing than it is an operating system thing. Some further data to support this would be that my old T61p running Windows 10 did not exhibit this problem (or at least I don't remember it doing so; I could be wrong) on version 18.1.27.30, and my X200 Tablet (a Trackpoint-only device) running Windows 8 also did not succumb.

Now, on the 4th-generation Carbon, Lenovo recommends version 19.0.17.135 for Windows 7 and 19.3.4.214 for Windows 10. On the X230, they recommend 19.0.17.137 for Windows 10, so we know that the problem goes back at least that far.

With that in mind, the question is where the cutoff point is (version 18 to 19, as I hypothesized, or someplace else) exactly. Once we find that out, the new question is whether the last "working" driver is still compatible with the latest builds of Windows 10 (as well as how it fares with 8.1, 7, etc.). And the bonus question, if the first two are satisfied, is if we still get to keep the "precision" pointing driver or if it goes back to the mucky, yucky, and generally-awful "non-precision" system.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 10”

Who is online

Users browsing this forum: No registered users and 4 guests