Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

3gmodem not detected

Linux on ThinkPads
Post Reply
Message
Author
corosus
Posts: 1
Joined: Tue Jan 19, 2016 5:58 pm
Location: brussels, Belgium

3gmodem not detected

#1 Post by corosus » Tue Jan 19, 2016 6:04 pm

Hi

i added a 3g modem to my thinkpad x200S recently

it worked for a day, and then stopped working
running debian sid

uname -a
Linux irregularapocalypse 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64 GNU/Linux

i suspect it's not a hardware problem since i see this in dmesg

dmesg | grep cdc
[ 4.361215] cdc_acm 6-4:1.1: ttyACM0: USB ACM device
[ 4.365044] cdc_wdm 6-4:1.5: cdc-wdm0: USB WDM device
[ 4.365144] cdc_wdm 6-4:1.6: cdc-wdm1: USB WDM device
[ 4.365180] usbcore: registered new interface driver cdc_wdm
[ 4.365774] cdc_acm 6-4:1.3: ttyACM1: USB ACM device
[ 4.367811] cdc_acm 6-4:1.9: ttyACM2: USB ACM device
[ 4.370063] usbcore: registered new interface driver cdc_acm
[ 4.370069] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 4.394577] cdc_ether 6-4:1.7 wwan0: register 'cdc_ether' at usb-0000:00:1d.7-4, Mobile Broadband Network Device, 02:80:37:ec:02:00
[ 4.394638] usbcore: registered new interface driver cdc_ether
[ 6.296279] cdc_ether 6-4:1.7 wwx028037ec0200: unregister 'cdc_ether' usb-0000:00:1d.7-4, Mobile Broadband Network Device



i tried with 2 different sims .. same result, so i know it's not the simcard


does anyone have an idea on what this might be ?


greetz

corosus

Punkoivan
Posts: 3
Joined: Mon Jan 04, 2016 4:47 pm
Location: Ukraine, Dnipropetrovsk

Re: 3gmodem not detected

#2 Post by Punkoivan » Tue Feb 02, 2016 3:41 am

Hi.
So, may be it affects with system update? But, Debian..
So, I can recommend to you install modem-manager-gui or just mmcli (modem-manager for console) and try to use it to detect your modem.
Ivan

Lomax
Freshman Member
Posts: 83
Joined: Tue Nov 01, 2005 1:16 pm
Location: London, UK

Re: 3gmodem not detected

#3 Post by Lomax » Mon Jul 17, 2017 10:35 am

I'm having the same problem, also tested with multiple (working) SIMs. It was working on 'buntu 12.04 but not since upgrading to 'buntu 14.04. I have lived with using my phone as an AP when out and about, but now I really need to get this working! I had hoped that a clean upgrade to 16.04 would resolve the issue, but alas the issue remains exactly the same; the CDC is detected and the driver is loaded during boot, but shortly thereafter the device is unregistered:

Code: Select all

[    9.649934] cdc_wdm 2-1.4:1.5: cdc-wdm0: USB WDM device
[    9.650166] cdc_wdm 2-1.4:1.6: cdc-wdm1: USB WDM device
[    9.650884] cdc_acm 2-1.4:1.1: ttyACM0: USB ACM device
[    9.650926] usbcore: registered new interface driver cdc_wdm
[    9.654661] cdc_acm 2-1.4:1.3: ttyACM1: USB ACM device
[    9.655259] cdc_acm 2-1.4:1.9: ttyACM2: USB ACM device
[    9.655598] usbcore: registered new interface driver cdc_acm
[    9.655601] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[    9.668138] cdc_wdm 2-1.4:1.6: wdm_int_callback - 0 bytes
[    9.678536] cdc_ether 2-1.4:1.7 wwan0: register 'cdc_ether' at usb-0000:00:1d.0-1.4, Mobile Broadband Network Device, 02:80:37:ec:02:00
[    9.678728] usbcore: registered new interface driver cdc_ether
[    9.681149] cdc_ether 2-1.4:1.7 wwp0s29u1u4i7: renamed from wwan0
[    9.686126] cdc_wdm 2-1.4:1.5: wdm_int_callback - 0 bytes
[   14.022625] cdc_ether 2-1.4:1.7 wwp0s29u1u4i7: unregister 'cdc_ether' usb-0000:00:1d.0-1.4, Mobile Broadband Network Device
Getting a little desperate here, so very grateful for any suggestions!
600E - 600X - 770X - X31 - X32 - T43p (SATA) - T60p - X200t - X61s - X200s - X201s (PVA) - Z Pro 9228

Lomax
Freshman Member
Posts: 83
Joined: Tue Nov 01, 2005 1:16 pm
Location: London, UK

Re: 3gmodem not detected

#4 Post by Lomax » Mon Jul 17, 2017 10:41 am

Digging a little deeper in dmesg shows that the event immediately preceding the CDC unregister is a USB disconnect:

Code: Select all

67092-[   14.019744] usb 2-1.4: USB disconnect, device number 3
67150:[   14.022625] cdc_ether 2-1.4:1.7 wwp0s29u1u4i7: unregister 'cdc_ether' usb-0000:00:1d.0-1.4, Mobile Broadband Network Device
This may or may not be relevant.
600E - 600X - 770X - X31 - X32 - T43p (SATA) - T60p - X200t - X61s - X200s - X201s (PVA) - Z Pro 9228

w0qj
Senior Member
Senior Member
Posts: 714
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: 3gmodem not detected

#5 Post by w0qj » Thu Jul 20, 2017 8:25 am

Any update on this issue?
Would be very interested in this matter, many thanks!

- - - - - - - - -
A significant number of our Thinkpad notebook computers have built-in OEM Mobile Broadband cards (WWAN);
this is why we stuck with Thinkpad (along with the great TrackPoint!).

But it is also Linux problems such as these (3G modem not detected error) that prevents us from jumping from Win10 to Linux!
Daily Driver: X1 Carbon 4th Gen (X1C4): i7-6600U 2.6GHz; 16GB DDR3 1866 MHz; 1TB PCIe-NVMe SSD; 14" WQHD 2560x1440; LTE EM7455 Mobile Broadband; Win7 Pro 64bit
Current Thinkpads: X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

Dekks
Senior Member
Senior Member
Posts: 514
Joined: Thu Jun 26, 2014 9:38 am
Location: Birmingham, UK

Re: 3gmodem not detected

#6 Post by Dekks » Thu Jul 20, 2017 10:11 am

apt install modem-manager-gui

that package worked for me in arch.
Home Win10/i5 Arch//Openbox R61//GNOME 3 X201i/X230 Tablet //Spectrwm T61/X61/X61 Debian 9.2/X32/T60p
Work - Win7/X220T BunsenLabs/Debian 9 T43
Retired T60/X30/X31/X61S RIP T400/T21/X61T/X200T

Lomax
Freshman Member
Posts: 83
Joined: Tue Nov 01, 2005 1:16 pm
Location: London, UK

Re: 3gmodem not detected

#7 Post by Lomax » Mon Nov 27, 2017 11:15 am

*bump*ing this in the hope someone can help. And no, installing Modem Manager GUI won't make the slightest bit of difference, since the modem is "unregistered" by the kernel during boot. The question is why this happens...
600E - 600X - 770X - X31 - X32 - T43p (SATA) - T60p - X200t - X61s - X200s - X201s (PVA) - Z Pro 9228

Lomax
Freshman Member
Posts: 83
Joined: Tue Nov 01, 2005 1:16 pm
Location: London, UK

Re: 3gmodem not detected

#8 Post by Lomax » Mon Nov 27, 2017 11:30 am

Here is the relevant Syslog output:

Code: Select all

Nov 27 16:00:52 thinkpad ModemManager[1029]: <info>  ModemManager (version 1.4.12) starting in system bus...
Nov 27 16:00:52 thinkpad mtp-probe: checking bus 2, device 3: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4"
Nov 27 16:00:53 thinkpad kernel: [    9.565703] cdc_wdm 2-1.4:1.5: cdc-wdm0: USB WDM device
Nov 27 16:00:53 thinkpad kernel: [    9.566208] cdc_wdm 2-1.4:1.6: cdc-wdm1: USB WDM device
Nov 27 16:00:53 thinkpad kernel: [    9.566384] usbcore: registered new interface driver cdc_wdm
Nov 27 16:00:53 thinkpad kernel: [    9.583566] cdc_wdm 2-1.4:1.6: wdm_int_callback - 0 bytes
Nov 27 16:00:53 thinkpad kernel: [    9.600561] cdc_wdm 2-1.4:1.5: wdm_int_callback - 0 bytes
Nov 27 16:00:53 thinkpad kernel: [    9.600692] cdc_acm 2-1.4:1.1: ttyACM0: USB ACM device
Nov 27 16:00:53 thinkpad kernel: [    9.605809] cdc_acm 2-1.4:1.3: ttyACM1: USB ACM device
Nov 27 16:00:53 thinkpad kernel: [    9.610154] cdc_acm 2-1.4:1.9: ttyACM2: USB ACM device
Nov 27 16:00:53 thinkpad kernel: [    9.614911] usbcore: registered new interface driver cdc_acm
Nov 27 16:00:53 thinkpad kernel: [    9.614918] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
Nov 27 16:00:53 thinkpad kernel: [    9.692798] cdc_ether 2-1.4:1.7 wwan0: register 'cdc_ether' at usb-0000:00:1d.0-1.4, Mobile Broadband Network Device, 02:80:37:ec:02:00
Nov 27 16:00:53 thinkpad kernel: [    9.705817] usbcore: registered new interface driver cdc_ether
Nov 27 16:00:53 thinkpad kernel: [    9.714631] cdc_ether 2-1.4:1.7 wwp0s29u1u4i7: renamed from wwan0
Nov 27 16:00:53 thinkpad NetworkManager[1013]: <info>  [1511798453.6719] devices added (path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.7/net/wwp0s29u1u4i7, iface: wwp0s29u1u4i7)
Nov 27 16:00:53 thinkpad NetworkManager[1013]: <info>  [1511798453.6731] device added (path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.7/net/wwp0s29u1u4i7, iface: wwp0s29u1u4i7): no ifupdown configuration found.
Nov 27 16:00:53 thinkpad NetworkManager[1013]: <info>  [1511798453.7136] ModemManager available in the bus
Nov 27 16:00:53 thinkpad NetworkManager[1013]: <info>  [1511798453.8911] device (wlp2s0): state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
Nov 27 16:00:54 thinkpad ModemManager[1029]: <info>  Couldn't find support for device at '/sys/devices/pci0000:00/0000:00:19.0': not supported by any plugin
Nov 27 16:00:54 thinkpad ModemManager[1029]: <info>  Couldn't find support for device at '/sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.0': not supported by any plugin
Nov 27 16:00:55 thinkpad ModemManager[1029]: <info>  Creating modem with plugin 'Ericsson MBM' and '6' ports
Nov 27 16:00:55 thinkpad ModemManager[1029]: <info>  Modem for device at '/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4' successfully created
Nov 27 16:00:58 thinkpad kernel: [   14.270765] usb 2-1.4: USB disconnect, device number 3
Nov 27 16:00:58 thinkpad ModemManager[1029]: <info>  (tty/ttyACM0): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4
Nov 27 16:00:58 thinkpad ModemManager[1029]: <warn>  Modem couldn't be initialized: couldn't load current capabilities: Failed to determine modem capabilities.
Nov 27 16:00:58 thinkpad kernel: [   14.278942] cdc_ether 2-1.4:1.7 wwp0s29u1u4i7: unregister 'cdc_ether' usb-0000:00:1d.0-1.4, Mobile Broadband Network Device
Nov 27 16:00:58 thinkpad ModemManager[1029]: <info>  (usbmisc/cdc-wdm0): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4
Nov 27 16:00:58 thinkpad ModemManager[1029]: <info>  (tty/ttyACM1): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4
Nov 27 16:00:58 thinkpad NetworkManager[1013]: <info>  [1511798458.0584] manager: (cdc-wdm1): new Broadband device (/org/freedesktop/NetworkManager/Devices/3)
Nov 27 16:00:58 thinkpad NetworkManager[1013]: <info>  [1511798458.0593] device (cdc-wdm1): state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Nov 27 16:00:58 thinkpad ModemManager[1029]: <info>  (usbmisc/cdc-wdm1): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4
Nov 27 16:00:58 thinkpad NetworkManager[1013]: <info>  [1511798458.0601] device (cdc-wdm1): modem state 'unknown'
Nov 27 16:00:58 thinkpad NetworkManager[1013]: <warn>  [1511798458.0604] (cdc-wdm1): failed to retrieve SIM object: No SIM object available
Nov 27 16:00:58 thinkpad NetworkManager[1013]: <info>  [1511798458.0681] devices removed (path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.7/net/wwp0s29u1u4i7, iface: wwp0s29u1u4i7)
Nov 27 16:00:58 thinkpad ModemManager[1029]: <info>  (net/wwp0s29u1u4i7): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4
Nov 27 16:00:58 thinkpad ModemManager[1029]: <info>  (tty/ttyACM2): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4
Nov 27 16:00:58 thinkpad NetworkManager[1013]: <info>  [1511798458.0966] device (cdc-wdm1): state change: unavailable -> unmanaged (reason 'removed') [20 10 36]
600E - 600X - 770X - X31 - X32 - T43p (SATA) - T60p - X200t - X61s - X200s - X201s (PVA) - Z Pro 9228

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Linux Questions”

Who is online

Users browsing this forum: No registered users and 5 guests